Archive

Posts Tagged ‘Eclipse’

Flex development on Linux

September 2, 2010 1 comment

Hey guys, I hope there are lot of guys who are relying on linux distro like Ubuntu, centos or fedora to name some. As far as the developers, geeks and machine fanatics are concerned. Aftyer such an addiction it’s quite difficult to work back on Windows system for some specific reasons like previous was the case as flash development is restricted to windows based machines. But now as adobe took a nice decision to move to bit to open source society with their new open source flexsdk the dream to develop flash based application on the linux island come true. Now with a handful of simple plugins our distro will be up and ready to develop application in flash and actionscript.

1. Download the eclipse euorpa with JEE support (v3.2 or higher)
Visit the following link http://www.eclipse.org/downloads/
Look for Eclipse IDE for Java EE Developers
32bit: http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/helios/R/eclipse-jee-helios-linux-gtk.tar.gz
64bit: http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/helios/R/eclipse-jee-helios-linux-gtk-x86_64.tar.gz

or get a torrent: http://build.eclipse.org/technology/phoenix/torrents/jee/eclipse-jee-helios-linux-gtk.tar.gz.torrent

Move the tar file into /opt dir
# sudo mv eclipse-*.tar /opt

Untar the eclipse compress file
# sudo tar zxvf eclipse-*.tar
# sudo cd eclipse
# ./eclipse &

2. Install the following plugins

In the menu, we choose Help -> Install new software…

Click on the “Add…” button, and type the following:

Name: Eclipse IMP
Location: http://download.eclipse.org/technology/imp/updates/

Name: AXDT
Location: http://update.axdt.org/

Choose (at least) the following packages:
Axdt AS3 Feature
Flex3SDK Feature

Then click on the “Next >” button, accept the licence and proceed to install the AXDT + Flex SDK framework.

Once installed, restart Eclipse

Go to the menu: Window -> Open perspective -> Other… -> AXDT

That’s all what you need to get started with Flas application development.

Coming soon

Tutorial: Write and compile you first flex application

Setting up Android Development Environment on Ubuntu

February 19, 2010 1 comment

# sudo apt-get update && sudo apt-get upgrade
# sudo apt-get install sun-java6-jdk
# apt-get install eclipse
While installing ADT plugin

Cannot complete the install because one or more required items could
not be found.
Software being installed: Android Development Tools
0.9.5.v200911191123-20404 (com.android.ide.eclipse.adt.feature.group
0.9.5.v200911191123-20404)
Missing requirement: Android Development Tools
0.9.5.v200911191123-20404 (com.android.ide.eclipse.adt.feature.group
0.9.5.v200911191123-20404) requires ‘org.eclipse.wst.xml.ui 0.0.0’ but
it could not be found

“Go to “Help/Install New Software…”

Add http://download.eclipse.org/releases/galileo/ to the update sites
list (strange it’s not installed by default on ubuntu)

>From there, install WST (use the filter box to find the package)

Restart eclipse

Go back to “Help/Install New Software…” and install the Android ADT
as explained on the android website.

Android SDK components
Add Android component as listed here under;-

  • Platform SDK
  • API
  • Documentation

Go to the following menu
Window >Android SDK and AVD Manager>Available Packages.

Categories: Android Tags: ,
%d bloggers like this: